23 Februari 2005

Konfigurasi Router untuk Redundancy dan Load Balancing ke Dua Internet Service Provider

originally posted at ilmukomputer-networking@yahoogroups.com

Bisa pakai Cisco router biasa, dua buah. Intinya musti punya lebih dari satu router (namanya juga redundant), pakai IOS yang support HSRP dan routing protocol yang mo digunakan.

Buat tau bisa HSRP atau nggak, coba ketik 'show standby'. Buat tau bisa dukung routing protocol apa aja, ketik 'show ip ?' terus lihat aja di list next available command. Kalo bisa ketik show ip ospf, berarti support OSPF. Kalo nggak bisa, coba upgrade IOSnya. AFAIK, yang ip-plus sudah support untuk HSRP dan OSPF. Coba cek di www.cisco.com.

Contoh konfigurasinya seperti ini. Sesuaikan IP address dengan desain dan layout network yang digunakan.



Router1
!
/*Inside interface*/
interface Ethernet0
ip address 192.168.202.189 255.255.255.224

/* Konfigurasi HSRP dengan virtual IP address 192.168.202.161
by default priority 100*/

standby 100 ip 192.168.202.161
standby 100 priority 100
!
/* Konfigurasi routing protocol OSPF*/
router ospf 1
log-adjacency-changes

/* network yang diikutsertakan pada OSPF adalah 192.168.202.160/27
gunakan wildcard bits 0.0.0.31 bukan subnet mask 255.255.255.224*/

network 192.168.202.160 0.0.0.31 area 0

/* distribute default route ke dalam OSPF dengan metric 5*/
default-information originate metric 5
!
/* default route ke ISP1*/
ip route 0.0.0.0 0.0.0.0 192.168.0.1!

Router2
!
/* inside interface*/
interface FastEthernet0/0
ip address 192.168.202.163 255.255.255.224

/* Konfigurasi routing policy pada inside interface*/
ip policy route-map ISP2

/* Konfigurasi HSRP dengan virtual IP address 192.168.202.161
gunakan priority yang lebih besar dari 100 agar jadi active HSRP router
gunakan preempt agar router ini bisa mengambil alih tugas sebagai active dari router lain*/

standby 100 ip 192.168.202.161
standby 100 priority 200
standby 100 preempt
!
/* Konfigurasi routing protocol OSPF*/
router ospf 1
log-adjacency-changes
network 192.168.202.160 0.0.0.31 area 0
!
/* default route ke ISP2 dengan metric 200*/
ip route 0.0.0.0 0.0.0.0 Serial0/0.1 200
!
/* interesting traffic list untuk routing policy ISP2*/
ip access-list extended mail-in
permit tcp host 192.168.202.166 eq smtp any
ip access-list extended vpn
permit ip host 192.168.202.175 any
permit esp host 192.168.202.175 any
permit ahp host 192.168.202.175 any
permit gre host 192.168.202.175 any
ip access-list extended smtp-out
permit tcp host 192.168.202.166 any eq smtp
permit udp host 192.168.202.166 any eq domain
permit tcp host 192.168.202.166 any eq domain
!
/* Konfigurasi routing policy ISP2*/
route-map ISP2 permit 10
match ip address smtp-out
!
route-map ISP2 permit 20
match ip address mail-in
set ip next-hop 192.168.202.254
!
route-map ISP2 permit 30
match ip address vpn
set ip next-hop 192.168.202.254
!

LAN menggunakan default gateway 192.168.202.161 (HSRP virtual IP address). Dengan konfigurasi tersebut Router2 yang aktif sehingga trafik akan dihandle oleh Router2.

Pada Router2, routing tablenya akan seperti berikut.

C 192.168.202.160/27 is directly connected, FastEthernet0/0
C 192.168.202.252/30 is directly connected, Serial0/0.1
O*E2 0.0.0.0/0 [110/5] via 192.168.202.189, 05:21:48, FastEthernet0/0


Karena default route yang diterima Router2 dari Router1 via OSPF memiliki metric lebih kecil (5) dibanding static default route ke ISP2 (metric 200) maka Router2 akan, by default, melempar paket ke Router1, bukan ke ISP2.

Routing policy dibuat agar trafik" yang kita inginkan dilempar ke ISP2 tidak dilempar ke ISP1 via Router1. Trafik smtp-out tidak diset ip next-hopnya karena itu dia akan diroute ke default route, yakni ke Router1. Jika suatu saat kita mau menggunakan ISP2 untuk smtp-out, tinggal menambahkan ip next-hop ke arah ISP2.

Jika link ke ISP1 putus, maka Router1 tidak akan punya default route ke 192.168.0.1 sehingga dia nggak akan advertise default routenya ke Router2. Akibatnya Router2 akan menggunakan default routenya yang ke ISP2.

Jika link ke ISP2 putus, maka Router2 tidak akan mengenal 192.168.202.252/30 sebagai directly-conneted to Serial0/0.1 sehingga trafik yang terkena routing policy pun akan dilempar ke default route ISP1 via Router1.

Jika Router1 mati, maka semua trafik akan lewat ISP2 karena Router2 akan menggunakan default routenya yang ke ISP2. Kasusnya hampir mirip dengan kasus link ke ISP1 mati.

Jika Router2 mati, maka Router1 akan mengambil alih tugas sebagai active HSRP router dan semua trafik akan dilempar ke ISP1.

2 Comments:

Anonymous rio di asnara101@gmail.com said...

permisi mas...

maaf saya mahasiswa it telkom yang sedang merancang konfigurasi redundant router, saya udah coba cari2 artikelnya dan saya uda mencoba namun saya masih bingung mengenai protocolnya dan konfigurasi tiap routernya.
saya menggunakan 2 buah PC router.

mohon penjelasannya.
terimakasih banyak

rio asnara
( asnara101@gmail.com )

30/11/08 11:56  
Blogger -=diekoe=- said...

Hai Rio,

PC router apa yang kamu gunakan? Saya pernah menggunanakan Zebra running on FreeBSD, dia support protokol OSPF untuk routing protocolnya. Tapi waktu itu belum support policy-based routing. Coba dicek lagi di manualnya mungkin sekarang sudah support PBR.

Konfigurasi zebra mirip dengan konfigurasi cisco router. Jadi bisa menggunakan konfigurasi yang ada di artikel ini sebagai contoh.

3/12/08 02:19  

Posting Komentar

<< Home